[M3commit] CVS Update: cm3

Jay K jay.krell at cornell.edu
Fri Jan 29 06:00:46 CET 2010


Thanks.

 

I depend heavily on plain text search, including "whole word".

I find that "language aware" tools are generally lacking

in availability, features, scale, ease of use.

 

 

Plain text search, augmented with a file system cache and/or

possibly an index, is available and scales and handles all

languages potentially.

 

 

This is an area where C really trumps C++, because

of the existance of namespaces and classes to scope

names that are broadly visible, you end up with function

names like "Init" instead of "WindowInit", etc.

Operator overloading is a problem too -- I can't

search for "+" on a particular type.

Modula-3 encourages these problems too I believe.

 

 

C's global namespace is usually considered a problem,

and it is, but it is also a feature.

 

 

This is also a reason to not use "file level static" in C.

Parameter names and local variable names don't seem to matter,

as they truly have small visiblity (well, parameter names in Modula-3 don't).

But function names, type names, record/object fields..

 

 

I am often lazy myself, but just forward me this email, call me a hypocrite,

go ahead and lengthen names I made too short. :)

 

 

I'm not sure what the difference is between var.vartype and mvar.mvartype.

mvar contains var.

I suspect var.vartype is "more correct for the data" and mvar.mvartype is the "type

of the access". Like, if I were to "split" an acces to a 64bit variable

into two access, var.vartype should be unchanged, mvar.mvartype can be changed.

I was going to be lazy and ask here, but then decided to try to read the code more.

 

 

These changes are not condusive to diffing, granted.

They add a lot of noise.

Stuck between two bad things I'm afraid there.

 

 

 - Jay

 
> Date: Thu, 28 Jan 2010 10:22:28 -0600
> From: rodney_bates at lcwb.coop
> To: m3commit at elegosoft.com
> Subject: Re: [M3commit] CVS Update: cm3
> 
> I highly support this kind of change. Very short identifiers
> are classic cases of sacrificing readability in favor of
> saving keystrokes during writing--a very bad tradeoff.
> The poor wretches who get/have to maintain the code pay the
> price for somebody else's laziness.
> 
> Jay Krell wrote:
> > CVSROOT: /usr/cvs
> > Changes by: jkrell at birch. 10/01/28 14:42:19
> > 
> > Modified files:
> > cm3/m3-sys/m3back/src/: Codex86.m3 M3x86.m3 M3x86Rep.i3 
> > Stackx86.m3 
> > 
> > Log message:
> > more renaming for readability (some just altering style of previous,
> > but also renaming more fields)
> > size => flit_size
> > proctype => proc_type
> > varsize => var_size
> > mvarsize => mvar_size
> > align => var_align
> > size => var_size
> > mvaroffset => mvar_offset
> > mvartype => mvar_type
> > etc.
> > 
> > 
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://m3lists.elegosoft.com/pipermail/m3commit/attachments/20100129/1f4640bd/attachment-0002.html>


More information about the M3commit mailing list