<html>
<head>
<style>
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
FONT-SIZE: 10pt;
FONT-FAMILY:Tahoma
}
</style>
</head>
<body class='hmmessage'>I'll be passing around backend mode a <EM>little </EM>more.<BR>
Should we make it an enum? Good names are hard to come up with here.<BR>
Here's my lame strawman:<BR>
<BR>
BackendMode =<BR> {<BR> IntegratedProducesObject,<BR> IntegratedProducedAssembly,<BR> QuakeProducesObject,<BR> QuakeProducesAssembly<BR> };<BR><BR>
I have these changes almost done but am going to remove them pending discussion. I don't really like these names.<BR>
They are long and still not all clear. Long would be ok if they were perfectly clear, imho.<BR>
These names do correlate well with the nearby comments, which get roughly repeated for every use of the magic numbers. "quake" is usually called "m3back" or such, the name of the Quake function. I find both descriptions a bit short and therefore unclear.<BR>
I don't think IntegratedProducingAssembly and QuakeProducingObject "really" exist.<BR>
There is m3staloneback -- QuakeProducingObject or Assembly, and the code is available for IntegratedProducingAssembly, I guess esp. for debugging, but you can just as well link /dump /disasm -- but I don't think these are really in use. Therefore, perhaps merely Object and Assembly, though Integrated vs. not is a significant aspect not represented..<BR>
<BR>
- Jay<BR><BR><BR><BR><BR><br /><hr />Connect and share in new ways with Windows Live. <a href='http://www.windowslive.com/share.html?ocid=TXT_TAGHM_Wave2_sharelife_012008' target='_new'>Get it now!</a></body>
</html>