[M3commit] CVS Update: cm3

Tony Hosking hosking at cs.purdue.edu
Mon Jul 5 23:35:38 CEST 2010

volatize is terminology from the gcc backend.  It is used only for exception frames.  I don't think you should make this change.

On 5 Jul 2010, at 23:25, Jay Krell wrote:

> CVSROOT:	/usr/cvs
> Changes by:	jkrell at birch.	10/07/05 23:25:58
> Modified files:
> 	cm3/m3-sys/m3cc/gcc/gcc/m3cg/: parse.c 
> Log message:
> 	rename "volatize" to "make_volatile"
> 	move existing code to function m3cg_make_volatile which
> 	will work for being called from front end, if we decide to do that
> 	(not done here)
> 	no real change here, just some renaming
> 	Note that the terminology is a bit off perhaps, in that
> 	I believe "volatile function" to gcc backend means
> 	"noreturn function". Here it means "all the locals, parameters,
> 	temporaries are volatile". ie. function calls setjmp/vfork.
> 	(This is actually overkill of course: it should only make
> 	volatile stuff used after the second return; this could actually
> 	still be defeating a fair amount of volatile removal -- any
> 	function with a "try".)

More information about the M3commit mailing list