[M3commit] CVS Update: cm3

Jay K jay.krell at cornell.edu
Thu Mar 14 06:00:40 CET 2013


backends shouldn't have to do this..


+PROCEDURE SubrangeCGType(READONLY min, max: Target.Int; bit_size: BitSize): M3CG.Type =
+(* duplicate the logic of m3front/src/types/SubrangeType;
+   m3front should pass us down cg_type directly, and not
+   bother with bit_size, domain *)
+BEGIN
+    IF TInt.EQ(min, TInt.Zero) AND TInt.EQ(max, TInt.MOne) THEN
+        RETURN BitsToCGInt[bit_size];
+    END;
+    IF TInt.LE(TInt.Zero, min) THEN
+        RETURN BitsToCGUInt[bit_size];
+    END;
+    RETURN BitsToCGInt[bit_size];
+END SubrangeCGType;



> Date: Thu, 14 Mar 2013 06:01:23 +0000
> To: m3commit at elegosoft.com
> From: jkrell at elego.de
> Subject: [M3commit] CVS Update: cm3
> 
> CVSROOT:	/usr/cvs
> Changes by:	jkrell at birch.	13/03/14 06:01:23
> 
> Modified files:
> 	cm3/m3-sys/m3back/src/: M3C.m3 
> 
> Log message:
> 	reversse-duplicate the logic of the frontend in determining cg_type
> 	for subranges because it fails to pass it down itself..lame..
> 
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://m3lists.elegosoft.com/pipermail/m3commit/attachments/20130314/32332ae4/attachment-0002.html>


More information about the M3commit mailing list