[M3commit] CVS Update: cm3
Jay K
jay.krell at cornell.edu
Sun Mar 7 23:29:50 CET 2010
Imagine you were writing a bounds check with INTEGER. Would you write:
a, min, max: INTEGER;
IF a >= min AND a <= max reasonable
IF min <= a AND a <= max reasonable
IF NOT a < min AND NOT max < a seems kind of contorted?
but ok.
- Jay
From: hosking at cs.purdue.edu
Date: Sun, 7 Mar 2010 11:03:51 -0500
To: jkrell at elego.de
CC: m3commit at elegosoft.com
Subject: Re: [M3commit] CVS Update: cm3
That's a cut-paste typo, not so much as any confusion in the comparison ops. I don't actually have much difficulty with the LT/LE comparisons versus the others you added. But... ok.
On 7 Mar 2010, at 15:12, Jay Krell wrote:
CVSROOT: /usr/cvs
Changes by: jkrell at birch. 10/03/07 15:12:18
Modified files:
cm3/m3-sys/m3front/src/builtinOps/: Number.m3
Log message:
Fix test p078.
Notice how the full assortment of LE/GE/LT/GT/EQ/NE makes it
easier to read and write the code and get it correct!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://m3lists.elegosoft.com/pipermail/m3commit/attachments/20100307/fa978aa9/attachment-0002.html>
More information about the M3commit
mailing list