[M3devel] 5.8.6 LINUXLIBC6 breakage, kernel 2.6.23, glibc-2.6-4

Mika Nystrom mika at async.caltech.edu
Thu Apr 7 21:02:19 CEST 2011

Remember that for mission-critical applications there's always user
threading..  I find that the system (up to and including the CVS head
and on both amd64 and i386 flavors of Linux as well as every other OS I
have tried) is very very stable with user threading.  I'm eager to use
pthreads again of course, for all sorts of reasons...


Tony Hosking writes:
>OK, sounds like the stability of the system is going downhill.  I'm not =
>sure when I'll have time to look at this.  Maybe soon, maybe in the =
>summer.  I am discouraged at all the reports we have been having about =
>these sorts of problems.
>On Apr 7, 2011, at 10:34 AM, Dragi=C5=A1a Duri=C4=87 wrote:
>> I am getting this, when my program does a Thread.Fork.
>> ***
>> *** runtime error:
>> ***    <*ASSERT*> failed.
>> ***    file "../src/thread/PTHREAD/ThreadPThread.m3", line 586
>> ***
>> Any ideas? It worked... And stopped working... Some changes were made =
>to openssl libraries and similar...
>> TIA,
>> dd

More information about the M3devel mailing list