[M3devel] python build problems

Coleburn, Randy rcolebur at SCIRES.COM
Sun Sep 8 05:48:00 CEST 2013


I'm still having lots of problems.

I installed python 2.7 on WinXP-32bit and tried upgrade.py against a working cm3 circa 2008.

I get the following error:

Traceback (most recent call last):
  File "C:\cm3\Sandbox\cm3\scripts\python\upgrade.py", line 4, in <module>
    import pylib
  File "C:\cm3\Sandbox\cm3\scripts\python\pylib.py", line 631, in <module>
    if Target.startswith("NT386"):
AttributeError: 'NoneType' object has no attribute 'startswith'

Looking at upgrade.py, it seems the first set of compilations is in the following order:
"import-libs", "m3bundle", "m3middle", "m3quake", "m3objfile",
                            "m3linker", "m3back", "m3front", "sysutils",
                            "cm3", "m3cggen", "mklib", "m3cgcat"

So, I tried to manually follow this order by cd to each folder, removing the NT386, running cm3, then cm3 -ship.  Things go well until I get to m3back, where I get the following error:

--- building in NT386 ---

ignoring ..\src\m3overrides

new source -> compiling TIntN.i3
new source -> compiling TIntN.m3
new source -> compiling TWordN.i3
new source -> compiling TWordN.m3
new source -> compiling M3x86.i3
new source -> compiling Wrx86.i3
new source -> compiling M3x86Rep.i3
new source -> compiling Codex86.i3
new source -> compiling Stackx86.i3
new source -> compiling M3x86.m3
new source -> compiling M3C.i3
new source -> compiling M3C.m3
"..\src\M3CC.i3", line 2: unable to find interface (Cstdint)
"..\src\M3CC.i3", line 4: undefined (Cstdint.int32_t)
"..\src\M3CC.i3", line 6: undefined (Cstdint.uint32_t)
3 errors encountered
new source -> compiling M3CC.i3
"..\src\M3CC.i3", line 2: unable to find interface (Cstdint)
1 error encountered
new source -> compiling Wrx86.m3
new source -> compiling Stackx86.m3
new source -> compiling Codex86.m3
new source -> compiling M3CC.c
new exporters -> recompiling M3C.i3
new exporters -> recompiling M3x86Rep.i3
compilation failed => not building library "m3back.lib"
Fatal Error: package build failed

Any suggestions on what to do?
I need to get a working cm3 on both WinXP and Win7 that is current with the HEAD branch.

BTW, it was my understanding that the compilation order was defined in "pkginfo.txt".  Has this changed, or is the file not up-to-date?  Reason I ask is that my RCC_upgradeCM3.cmd used to work fine and it bases the order on pkginfo.txt, yet you remarked in a previous post that I was leaving something out, plus it seems the order in upgrade.py doesn't match what you find in pkginfo.txt.  Please advise.

Randy Coleburn
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://m3lists.elegosoft.com/pipermail/m3devel/attachments/20130908/cdd75883/attachment-0001.html>

More information about the M3devel mailing list