[M3devel] I need more cvs help

Rodney M. Bates rodney_bates at lcwb.coop
Sun Feb 9 03:22:14 CET 2014

On 02/06/2014 10:32 AM, Olaf Wagner wrote:
> On Thu, 06 Feb 2014 10:00:35 -0600
> "Rodney M. Bates" <rodney_bates at lcwb.coop> wrote:
>> I am trying to move some small subdirectories.  In my local copy, I created the new
>> directories, did cvs add on them, copied the source files to the new directories,
>> did cvs add and cvs commit on them, in the new directories.  On this machine, it
>> looks like it worked, and CVS/Entries shows the new version numbers the commit showed.
>> But doing cvs update -d on a different machine gets nothing.
>> Moreover, the commit messages coming through on m3commit show the files as
>> committed in the directory where the old copies were.  CVS/Entries there also
>> shows the new version numbers.  And cvs update in the old directory not only gets
>> the new versions, that were committed from the new directory, but it gets some
>> other files that came from a different subdirectory too.
>> Surely, cvs can't be treating files in different directories with the same simple
>> name as the same file.  We have tens, maybe hundreds of files named "m3makefile"
>> all over, and these don't get mixed up in this way.
>> Any help would be greatly appreciated.
> It sounds like you did it right, yet I am sure that you somewhere made
> a mistake. Are you sure you didn't copy any metadata (CVS/xxx) around?

That's possible,
> Have you got a log of the commands you executed, or can you retry
> the move/add/commit/remove and record the session?

but I don't have enough info to reconstruct the sequence, especially after
a hard disk just went sick.

I tried saving everything I care about off to the side, removing all of
both subdirectories from cvs, and re-adding from scratch.  I even changed
the name of the top new subdirectory, which wasn't consistent anyway.
This appears to have worked, finally.

The directories to be removed were dens of werewolves.  cvs, it seems,
won't remove anything that is in an inconsistent state, and even when
it did, it seemed to take many repetitions to get it done both in the
repository and my local copy.

> Olaf

More information about the M3devel mailing list