[M3devel] I need more cvs help

Rodney M. Bates rodney_bates at lcwb.coop
Sun Feb 9 16:26:23 CET 2014

On 02/09/2014 05:46 AM, Olaf Wagner wrote:
> On Sat, 08 Feb 2014 20:22:14 -0600
> "Rodney M. Bates" <rodney_bates at lcwb.coop> wrote:
>> On 02/06/2014 10:32 AM, Olaf Wagner wrote:
>>> On Thu, 06 Feb 2014 10:00:35 -0600
>>> "Rodney M. Bates" <rodney_bates at lcwb.coop> wrote:
> [...]
>>>> Any help would be greatly appreciated.
>>> It sounds like you did it right, yet I am sure that you somewhere made
>>> a mistake. Are you sure you didn't copy any metadata (CVS/xxx) around?
>> That's possible,
>>> Have you got a log of the commands you executed, or can you retry
>>> the move/add/commit/remove and record the session?
>> but I don't have enough info to reconstruct the sequence, especially after
>> a hard disk just went sick.
>> I tried saving everything I care about off to the side, removing all of
>> both subdirectories from cvs, and re-adding from scratch.  I even changed
>> the name of the top new subdirectory, which wasn't consistent anyway.
>> This appears to have worked, finally.
>> The directories to be removed were dens of werewolves.  cvs, it seems,
>> won't remove anything that is in an inconsistent state, and even when
>> it did, it seemed to take many repetitions to get it done both in the
>> repository and my local copy.
> So I gather that you've resolved the problem and cleaned up the
> source tree. CVS is known to have problems with refacturing code,
> as it does not treat directories as versioned objects.

Yes, as far as I can tell, it is resolved.

> Olaf

More information about the M3devel mailing list