[M3devel] build problems with "elego\prjm"

Coleburn, Randy rcolebur at SCIRES.COM
Thu May 29 23:42:09 CEST 2014


I've performed a clean rebuild of everything, but I still get the same error with "elego\prjm".
I'm also finding that "libunicode" is trying to build, yet there is no "Unicode_WIDECHAR" definition in the cm3.cfg files.
BTW, my target is NT386.

--Randy Coleburn

From: jayk123 at hotmail.com [mailto:jayk123 at hotmail.com] On Behalf Of Jay K
Sent: Thursday, May 29, 2014 3:26 AM
To: Coleburn, Randy; m3devel
Subject: EXT:RE: [M3devel] build problems with "elego\prjm"

This might be a "builder" incrementality problem,
related to that this module was moved from libm3
to m3core, a while ago.

I don't think we cope with such movement correctly.

Can you be sure to clean rebuild m3core, libm3,
and prjm, and maybe everything else?

Given the unicode problem, maybe not.

 - Jay

From: rcolebur at SCIRES.COM<mailto:rcolebur at SCIRES.COM>
To: m3devel at elegosoft.com<mailto:m3devel at elegosoft.com>
Date: Thu, 29 May 2014 05:44:29 +0000
Subject: [M3devel] build problems with "elego\prjm"
I've been rebuilding everything from the HEAD branch on Windows XP (32-bit).

The "elego\prjm" package fails to build (see errors below).

I haven't taken time yet to look at the source code, but wanted to go ahead and post these results to the group in case someone wants to work on a solution.

Randy Coleburn

--- processing package "elego\prjm" ---
--- purging derived files from NT386 ---

--- cleaning NT386 ---

ignoring ..\src\m3overrides

--- building in NT386 ---

ignoring ..\src\m3overrides

C:\cm3\bin\m3bundle -name ProjectManagerBundle -element UsageHelp ..\src\UsageHelp -element compactrc ..\src\compactrc -element ShortUsageHelp ..\src\ShortUsageHelp
new source -> compiling ProjectManagerBundle.i3
new source -> compiling ProjectManagerBundle.m3
new source -> compiling Creation.i3
new source -> compiling Creation.m3

Fatal Error: bad version stamps: TimePrjDescTbl.i3

missing export: LongrealType.T imported by TimePrjDescTbl.i3
missing export: LongrealType.Brand imported by TimePrjDescTbl.i3

WARNING:  Encountered an error when processing package "elego\prjm" for "-build".
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://m3lists.elegosoft.com/pipermail/m3devel/attachments/20140529/749b6377/attachment-0002.html>

More information about the M3devel mailing list